25 abril 2009

Ati en Jaunty II


Acabo de leer un Desde Ubuntu para el Mundo una posible solución para la instalación de los Drivers de Ati (propietarios) en ubuntu Jaunty, que pasaría por descargar el instalador desde la web oficial.

Antes de continuar comprueba que no tienes la opción de activar los drivers privativos de Ati desde el gestor de Drivers privativos del propio Ubuntu ya que si seguís los pasos que ahora mismo os voy a comentar puede que os quedéis sin poder arrancar... avisados quedáis.

Antes de proseguir nos aseguramos que tenemos todo lo necesario:
  • sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++5 dkms
Ahora sí, vamos a crear los paquetes para nuestra distribución:
  • sh ati-driver-installer-9-4-x86.x86_64.run --buildpkg Ubuntu/jaunty
Una vez hecho esto nos creará los paquetes .deb para nuestra distribución, instalamos los siguiente:

Para 32 bits:
  • sudo dpkg -i xorg-driver-fglrx_*.deb fglrx-kernel-source_*.deb fglrx-amdcccle_*.deb
Ahora hacemos una copia de seguridad de xorg.conf y reconfiguramos
  • sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf-copia
  • sudo dpkg-reconfigure xserver-xorg
Editamos xorg.conf y nos aseguramos de que tenemos la siguiente línea:
  • sudo gedit /etc/X11/xorg.conf
Section "Device"
[...]
Driver "fglrx"
[...]
EndSection
Sin las [...] obviamente.

Ahora tecleamos:
  • sudo aticonfig --initial -f
Si no hay ningún error todo va bien.

En algunos casos los cambios en xorg.conf no tiene lugar, para forzar que esto sea así, tecleamos los siguiente:
  • sudo aticonfig --input=/etc/X11/xorg.conf --tls=1
Cruzamos los dedos, reiniciamos y si todo parece ir bien nos vamos a una consola, tecleamos esto
fglrxinfo y esperamos a que nos aparezca algo parecido a esto:
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 3850
OpenGL version string: 2.1.8304 Release
Ahora solo por lo que pueda pasar, recuerda que Ctrl+Alt+Borrar no funciona en Jaunty para matar las X, y si tampoco puedes hacerlo con Ctrl+Alt+F1 la solución para matar salir del sistema sin ser bastos y darle al botón sería:
Alt+ImprPant+r, Alt+ImprPant+s, Alt+ImprPant+e, Alt+ImprPant+i, Alt+ImprPant+n, Alt+ImprPant+u, Alt+ImprPant+b (rseinub).
Bueno, esto siempre y cuando tu tarjeta tenga gráfica esté todavía soportada por ATI, yo aun no lo he probado y no sé cuando lo haré (recordad que me tocó reinstalar después de mi primer intento con ATI).

Cualquier comentario o aporte sería de gran ayuda.

Visto en Desde Ubuntu para el Mundo
Mucha más info aquí.
Imágen DeviatArt.

11 comentarios:

  1. daniel18:35

    Una preguntilla, si el driver que te recomienda ATI se llama ati-driver-installer-9-3-x86.x86_64, el procedimiento a seguir es el mismo, no??
    Es que mi tarjeta gráfica es una Radeon mobility X600, y no tengo claro con que driver funciona, aunque el hardy y en intrepid no me dio problemas

    Un saludo

    ResponderEliminar
  2. daniel18:50

    Ay joder que miedo!!
    no se que carajo ha pasado pero me he tenido que poner la configuracion default.
    Me ha salido un pantallazo azul al estilo windows al reiniciar y me daba la opcion de reconfigurar manualmente y la de volver a la conf default, asi que eso he hecho, que va bien pero podria ir mejor...
    Si alguien tiene alguna idea de que se puede hacer que lo comente, ya que parece que esta solucion a mi no me funciona.
    Espero que a los demas si

    ResponderEliminar
  3. A que caray.... me estaba animando a cambiar mi Hardy por Jaunty, pero por lo visto me quedare con las ganas ya que estoy de ATI si que son "listos" al decapitar el soporte de sus drivers a las graficas viejitas que por lo general traen las laptops.....

    Ahora ya que, los drivers del gestor de drivers privativos, van bien, no tienen fallos ???

    ResponderEliminar
  4. @Daniel, si se llaman de otra manera no hay problema, es el número de la versión, sigue los mismos pasos.

    @Prueba de Uranio23, si te aparecen los privativos (a mi no) van "la mar" de bien, o sea que si, van de lujo.

    ResponderEliminar
  5. Lo acabo de probar y no me funciono, Aparece una Ayuda despues de cargar Ubuntu, informandome que no se pudieron cargas las X, y me da unas opciones para solucionarlo, ya las probe, pero no nos sirven ya que nos deja sin aceleracion de todos modos.

    Si les pasa eso, para revertir el problema, (ya que tenia aceleracion primero con los drivers libre, pobre pero tenia).
    Simplemente regrese xorg.conf a su original, y desinstale los paquetes que habia instalado, simple.

    Saludos ;)

    PD. Ya actualize a Jaunty y creo que asi esta excelente, no me urge la aceleracion, bueno solo para jugar World of Goo :(, pero por lo demas me quedo con Jaunty, peeero con Hardy los drivers me funcionaban como hueso :( me habia olvidado de los problemas de aceleracion.

    Ahora a esperar a que los de AMD se alivianen como decimos en Mexico.

    ResponderEliminar
  6. olwepro06:30

    Gracias por mejorar un poco la guia para los demas usuarios, yo en mi caso probe de primera pasada instalara los que me daba por restricted, pero no me fuinciono, luego de buscar mucho y leer, pude llegar a eso. Fue la unica salvacion para mi HD3850 de ati.

    Saludos cordiales desde chile

    Jonathan Castro - Olwepro

    ResponderEliminar
  7. Yo tengo mi ATI X1300 y con mi Hardy me va perfecto, con el Jaunty ni se ve... tengo que montar unas historias impresionantes, creo que no esta soportadas. Para esto tengo 2 soluciones
    -Pasarme a Nvidia
    -Pasarme a Nvidia si quiero migrar

    No obstante lo tuyo es muy bueno, muchisimas gracias por los consejos.

    ResponderEliminar
  8. A mi me funcionó perfectamente, y eso que mi gráfica en la anterior versión de Ubuntu ni encendía la pantalla en modo seguro. Mi gráfica es una HD2600 Pro 512MB AGP (por ser AGP no tengo ni buen soporte en Windows)

    ResponderEliminar
  9. Anónimo19:54

    Todo aquel que tenga ATI X.... (yo incluido con una x1600pro y varias horas de machaque) la lleva clara.

    Según las release notes de los catalyst 9.4 sólo soporta las HD, por eso te funciona bien. También comunican que no darán más soporte puesto que van a evolucionar sobre DirectX10 y no le van a dedicar más tiempo a esas tarjetas que solo soportan hasta DX9.

    Soluciones que es a lo que vamos:

    1.- Pasarse a nvidia o comprarse otra ati más moderna.
    2.- Volver a Intrepid que iba muy bien con los 9.3. Jaunty viene con el xorg 1.6 que no está soportado por los 9.3 ni ningun otro. Hay que aguantarse sin poder usar fglrx.
    3.- Esperar que vayan mejorando los driver publicos de jaunty.

    Ea. Eso es lo que hay... por ahora.

    Saludos y suerte con lo que hagáis. ;)

    ResponderEliminar
  10. La solución pasa por cambiarse a Nvidia y no volver a comprar una tarjeta gráfica AMD/Ati en la vida.

    ResponderEliminar
  11. @Lucifer es una muy acertada observación, solo que un poco complicada de llevar a cabo en un ordenador portátil... pero en el equipo sobre-mesa hace mucho tiempo que uso Nvidia...

    ResponderEliminar